Apache 2.4 – Error during SSL Handshake with remote server

Issue:

Error during SSL Handshake with remote server Usually happens with the following scenario

Server 1 – Apache as SSL proxy to server2
Server 2 – Runs the web service such as apache or nginx

Environment:

This issue usually happens with apache 2.4.x

Resolution:

To solve this issue, Just add the following configuration to the Apache SSL Proxy configuration on server 1,

Just After “SSLProxyEngine On” add

=====
SSLProxyCheckPeerCN Off
SSLProxyCheckPeerName Off
=====

The above variables are Off by default in versions older than Apache 2.4. So we need to to turn it Off in the configuration manually on Apache 2.4.

Verify your configurations:

# httpd -t

Finally, Restart the service “service httpd restart” Now access the website, It should work perfectly.

If not, Just comment below with the details.